$re = '/([^|]*)/';
$str = 'sample-search-cdn|nz|nz--cdn|||||generic-produce-luxury-gdn|||generic-value|||| ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);