#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\$\{\$\{([\w-_\[\]]*?)\}\}|\$\{([\w-_\[\]]*?)\}|\$\{(((.*?)\})+)"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"${${IP}${hi}${hello}${ab${cd}ef}${CUPM_IP}}" & @CRLF & _
"${LAST-NA[M]E}" & @CRLF & _
"${[BRACKETS]}" & @CRLF & _
"" & @CRLF & _
"${CP_IM} ${b} ${1} ${} ${LAST-NAM[E]} ${12} ${34}${56} ${[BRACKETS]}" & @CRLF & _
"" & @CRLF & _
" hello test b ${hg ${$} ${hello word} ${12-34_ab%}" & @CRLF & _
"" & @CRLF & _
"${hg ${$}}" & @CRLF & _
"" & @CRLF & _
"${${hi}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")