package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).o[^o]`)
var str = `do`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}