import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w\\s./-]*(?:\\s\\d+){4}(?:\\s\\$\\d+\\.\\d+){2}$";
final String string = "Amount\n"
+ "2144-PL\n"
+ "1XL 2XL 3XL\n"
+ "2144-\n"
+ "PL Navy Blue 2 2 2 6 $11.50 $69.00\n"
+ "ETK-2097K-PL PLUS-TOP - BACK BUTTON TUNICS 95% RAYON 5% SPANDEX MADE IN USA\n"
+ "1XL 2XL 3XL\n"
+ "Black 2 2 2 6 $12.00 $72.00\n"
+ "Teal 2 2 2 6 $12.00 $72.00\n"
+ "ETK-2197-SW-\n"
+ "1XL 2XL 3XL\n"
+ "PL ETK-\n"
+ "2197- H.Grey/Burgu… 2 2 2 6 $14.00 $84.00\n"
+ "Off-White/Black 1 1 1 3 $14.00 $42.00\n"
+ "ETK-2143 Tops - 95% RAYON 5% SPANDEX MADE IN USA\n"
+ "S M L\n"
+ "Heather Grey 2 2 2 6 $10.50 $63.00\n"
+ "Royal Blue 2 2 2 6 $10.50 $63.00\n"
+ "Ruby Red 2 2 2 6 $10.50 $63.00\n"
+ "ETK2186-GD- Tops-Stripe Solid-95% Rayon 5% Spandex Made in USA\n"
+ "PL\n"
+ "1XL 2XL 3XL\n"
+ "Burgundy/Bur… 2 2 2 6 $11.00 $66.00\n"
+ "Ivory/Black 2 2 2 6 $11.00 $66.00\n"
+ "2139 - WP-PL PLUS TOP -95% RAYON 5% SPANDEX MADE IN USA\n"
+ "1XL 2XL 3XL\n"
+ "As Shown 2 2 2 6 $9.50 $57.00\n"
+ "ETK-2228\n"
+ "S M L\n"
+ "ETK- \n"
+ "2228 Off-White/Black 2 2 2 6 $9.50 $57.00\n"
+ "ETK-2149-PL\n"
+ "1XL 2XL 3XL\n"
+ "ETK-\n"
+ "2149- Taupe 2 2 2 6 $11.50 $69.00\n"
+ "BACK\n"
+ "ORDERED\n"
+ "White 2 2 2 6 $11.50 $69.00\n"
+ "Sub";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}