const regex = /^.*\bAPPLE.*\bPIE[\s\d]*[^-]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\bAPPLE.*\\bPIE[\\s\\d]*[^-]*$', 'gm')
const str = `SWEET APPLE 1 - PIE 2
SWEET APPLE 1 - PIE 2 IS GOOD
SWEET APPLE 1 - PIE3
SWEET APPLE 1 - PIE 1-3 IS GOOD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}