re = /^(\"[^"\/]*\"|[^"\/]*\/?)+$/im
str = '"hello/world"
hello/world/"How are you"
"test"
test
test/""/test
test"test/"/test/test/'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result