$re = '/(?:^|\G)(\d{1,3})(?=(\d{3})+(?:\.\d+)?$)/m';
$str = '1829383839.2937484
1234567890';
$subst = "$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;