using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]*""(*SKIP)(*F)|\b100\b";
string substitution = @"";
string input = @"<p alt=""100"">100</p>
<img src=""100.jpg"">100</ing>
<span alt=""tel:100"">100</span>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}