$re = '/"[^"]*"(*SKIP)(*F)|\b100\b/m';
$str = '<p alt="100">100</p>
<img src="100.jpg">100</ing>
<span alt="tel:100">100</span>
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;