$re = '/href="(.+?)(\.css).*?"/';
$str = '<link rel="stylesheet" type="text/css" href="css/site_global.css?366877458"/>
<link rel="stylesheet" type="text/css" href="css/master_trimestre.css?4021764086"/>
<link rel="stylesheet" type="text/css" href="css/eltrimestre.css?3970103658" id="pagesheet"/>';
$subst = "href=\"{{ asset(\"static/$1$2\") }}\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;