const regex = /\((.*)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((.*)\\)', 'g')
const str = `var str1 = 'aggregate([{\$group:{_id:{state:"\$state",city:"\$city"},sum:{\$sum:"\$pop"}}},{\$sort:{sum:1}},{\$group:{_id:"\$_id.state",smallestcity:{\$first:"\$_id.city"},smallest:{\$first:"\$sum"},largestcity:{\$last:"\$_id.city"},largest:{\$last:"\$sum"}}}])'
var str2 = 'find({awards:{\$elemMatch:{award:"Turing Award",year:{\$gt:1980}}}}).limit(0)'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}