import Foundation
let pattern = #"(images/)(*SKIP)(*F)|([^/]*)/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"images/Qcuj/lXOSWNDwF/FmSgCbQ==.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)