using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:turn (?:on|off))|toggle) (\d+),(\d+) through (\d+),(\d+)$";
string input = @"turn off 0,0 through 999,999";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}