package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:turn (?:on|off))|toggle) (\d+),(\d+) through (\d+),(\d+)$`)
var str = `turn off 0,0 through 999,999`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}