$re = '/(?<year>\d{4})[\\\\\/](?<month>\d{2})(?:[\\\\\/](?<day>\d{2}))?$/m';
$str = 'somepath/yyyy/mm/dd
path/2014/10/12
path/2013/11
path\\2014\\01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);