$re = '~\s* ( \[some_element\] ( (?: .* | (?1) )* ) \[/some_element\] ) ~x';
$str = '[some_element]Random string chars [some_element]Ramdon[/some_element] some more random chars[/some_element]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);