# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
# Define the opening and closing elements before the recursion occurs
(?(DEFINE)
(?<open_curly>\{)
(?<close_curly>\})
(?<open_square>\[)
(?<close_square>\])
(?P<open_pascal>(?i:\bbegin\b))
(?P<close_pascal>(?i:\bend\b))
(?P<open_lua>--\[)
(?P<close_lua>--\])
(?<open>\g'open_curly'|\g'open_square'|\g'open_pascal'|\g'open_lua')
(?<close>\g'close_curly'|\g'close_square'|\g'close_pascal'|\g'close_lua')
)
# Match the opening element
(\g'open'
(?>
# For recursion, don't match either the opening
# or closing element
(?!\g'open'|\g'close')(.)
|
# Recurse this captured pattern
(?-1)
)*
# Match the closing element
\g'close')
"""
test_str = ("EVENLY BALANCED curly braces\n\n"
"{{{}}}\n"
"{ test1 { test2 { test3 { test4 } } } }\n\n"
"UNEVENLY BALANCED curly braces\n"
"{{{{}}}\n"
"{ test1 { test2 { test3 { test4 } } } } }\n\n"
"MULTI-LINE EVENLY BALANCED curly braces\n"
"{\n"
"}\n\n"
"MULTI-LINE UNEVENLY BALANCED curly braces\n"
"{{\n"
"}\n\n\n"
"EVENLY BALANCED square braces\n"
"[ test1 [ test2 [ test3 [ test4 ] ] ] ]\n\n"
"EVENLY BALANCED square and curly braces\n"
"{ test1 [ test2 { test3 [ test4 ] } ] }\n\n"
"UNEVENLY BALANCED square and curly braces\n"
"{ test1 [ test2 { test3 [ test4 ] } } ]\n")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.