const regex = /^(/index\.php/Cdiscount/Package/download/type/offers/filename/BMS_PREFIX_)(.+)/BMS_PREFIX_(.+).zip/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\/index\\.php\/Cdiscount\/Package\/download\/type\/offers\/filename\/BMS_PREFIX_)(.+)\/BMS_PREFIX_(.+).zip', '')
const str = `/index.php/Cdiscount/Package/download/type/offers/filename/BMS_PREFIX_161d529d7c3ef4b5ae1dca92e2334de6/BMS_PREFIX_161d529d7c3ef4b5ae1dca92e2334de6.zip
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);