$re = '/(?<=\.)([^\W\d\_])/m';
$str = 'Run-D.m.C.
Run-D.M.c.
Run-D.m.c.
Run-d.m.c.
R.E.M.
r.E.M.
R.e.M.
R.e.m.
r.e.m.';
$subst = "\U$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;