using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^>]+(?=<\/a>)";
string input = @"<a href=""http://google.com"">Google</a>
<a href=""http://apple.com"" title=""Apple, Inc."">Apple</a>
<a title=""Microsoft, Inc."" href=""http://microsoft.com"">Microsoft</a>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}