re = /[^>]+(?=<\/a>)/mi
str = '<a href="http://google.com">Google</a>
<a href="http://apple.com" title="Apple, Inc.">Apple</a>
<a title="Microsoft, Inc." href="http://microsoft.com">Microsoft</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end