package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\s\.\(]*(m|k?)(\w+)[\s\.\)]*`)
var str = `mBtu(th).ft
kBtu(th)ft`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}