#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "class="checkStatusNowLink" href="([^"]+)"
Local $sString = "Some text will come here <a class="checkStatusNowLink" href="https://something.com" style="color: rgb(255, 255, 255); font-size: 17px;">Check Status</a>. Some text will come here <a href="#">Click</a> Some text will come here."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")