// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"class="checkStatusNowLink" href="([^"]+)"#).unwrap();
let string = "Some text will come here <a class=\"checkStatusNowLink\" href=\"https://something.com\" style=\"color: rgb(255, 255, 255); font-size: 17px;\">Check Status</a>. Some text will come here <a href=\"#\">Click</a> Some text will come here.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}