import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\btime\\b)[^.^\\[\\]\\{\\}\\n]*$";
final String string = "testtime -> allowed\n"
+ "testTime -> allowed\n"
+ "tim etest -> allowed\n"
+ "thetimetest -> allowed\n"
+ "the time test -> not allowed\n"
+ "test[my -> not allowed\n"
+ "my}test -> not allowed\n"
+ "test^time -> not allowed";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}