package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\([^)]+\)|\d+|\D)`)
var str = `45+(30*2)<=50`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}