#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "19[5-9]\d|20[0-4]\d|2050"
Local $sString = "1990 - 2010" & @CRLF & _
"1990-2022" & @CRLF & _
"2050" & @CRLF & _
"2000" & @CRLF & _
"" & @CRLF & _
"2049" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")