# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"19[5-9]\d|20[0-4]\d|2050"
test_str = ("1990 - 2010\n"
"1990-2022\n"
"2050\n"
"2000\n\n"
"2049\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.