using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?:\s|\.|_|\-|\+|\(|\[))(?:19[2-9]|20[0-2])\d(?=\s|$|\.|_|\-|\+|\)|\])";
string input = @"1919
1920
1999
2001
2029
2030
Mute 2018 1080p NF WEB
Mute.2018.1080p.NF.WEB
Mute_2018_1080p NF WEB
Mute-2018-1080p
Mute(2018)1080p
Mute[2018]1080p
Mute+2018+1080p
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}