import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(?:\\s|\\.|_|\\-|\\+|\\(|\\[))(?:19[2-9]|20[0-2])\\d(?=\\s|$|\\.|_|\\-|\\+|\\)|\\])";
final String string = "1919\n"
+ "1920\n"
+ "1999\n"
+ "2001\n"
+ "2029\n"
+ "2030\n"
+ "Mute 2018 1080p NF WEB\n"
+ "Mute.2018.1080p.NF.WEB\n"
+ "Mute_2018_1080p NF WEB\n"
+ "Mute-2018-1080p\n"
+ "Mute(2018)1080p\n"
+ "Mute[2018]1080p\n"
+ "Mute+2018+1080p\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}