const regex = /(?<=(?:\s|\.|_|\-|\+|\(|\[))(?:19[2-9]|20[0-2])\d(?=\s|$|\.|_|\-|\+|\)|\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(?:\\s|\\.|_|\\-|\\+|\\(|\\[))(?:19[2-9]|20[0-2])\\d(?=\\s|$|\\.|_|\\-|\\+|\\)|\\])', 'gm')
const str = `1919
1920
1999
2001
2029
2030
Mute 2018 1080p NF WEB
Mute.2018.1080p.NF.WEB
Mute_2018_1080p NF WEB
Mute-2018-1080p
Mute(2018)1080p
Mute[2018]1080p
Mute+2018+1080p
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}