use strict;
my $str = '1919
1920
1999
2001
2029
2030
Mute 2018 1080p NF WEB
Mute.2018.1080p.NF.WEB
Mute_2018_1080p NF WEB
Mute-2018-1080p
Mute(2018)1080p
Mute[2018]1080p
Mute+2018+1080p
';
my $regex = qr/(?<=(?:\s|\.|_|\-|\+|\(|\[))(?:19[2-9]|20[0-2])\d(?=\s|$|\.|_|\-|\+|\)|\])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}