$re = '/(?<=(?:\s|\.|_|\-|\+|\(|\[))(?:19[2-9]|20[0-2])\d(?=\s|$|\.|_|\-|\+|\)|\])/m';
$str = '1919
1920
1999
2001
2029
2030
Mute 2018 1080p NF WEB
Mute.2018.1080p.NF.WEB
Mute_2018_1080p NF WEB
Mute-2018-1080p
Mute(2018)1080p
Mute[2018]1080p
Mute+2018+1080p
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);