use strict;
my $str = 'X:\\East\\_Complete Downloads\\[2ndfire]Haibane_Renmei[BD][1080p][Dual-Audio][AV1][10bit]\\Haibane Renmei - S01E01 - Cocoon Dream.mkv';
my $regex = qr/^.*\\(\[.*?\]).[^\[]+(\[.*\])\\.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}