// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*\\(\[.*?\]).[^\[]+(\[.*\])\\.*").unwrap();
let string = "X:\\East\\_Complete Downloads\\[2ndfire]Haibane_Renmei[BD][1080p][Dual-Audio][AV1][10bit]\\Haibane Renmei - S01E01 - Cocoon Dream.mkv";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}