package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\w\d{7}\b`)
var str = `http://photos.v3.torontomls.net/Live/photos/FULL/1/270/E3285270.jpg?20150812131646`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}