$re = '/[\r\n]?BEGIN((?!TRUE).)*?END/s';
$str = 'BEGIN
DESCRIPTION: 1234
BOOL:TRUE
END
BEGIN
DESCRIPTION: 4568
BOOL:TRUE
END
BEGIN
DESCRIPTION: 715310
BOOL:FALSE
END
BEGIN
DESCRIPTION: 12489453
BOOL:TRUE
END
BEGIN
DESCRIPTION: 41543
BOOL:FALSE
END';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;