const regex = /(([0-2][0-9]|3[0-1])([0][0-9]|[1][0-2])(19|20[0-9][0-9]))[.]zip/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([0-2][0-9]|3[0-1])([0][0-9]|[1][0-2])(19|20[0-9][0-9]))[.]zip', '')
const str = `09062015.zip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}