$re = '/"(?:[^"](?:\\\\.[^"]+)?)+"(*SKIP)(*FAIL)|(?!.*:);(?=[^:]*$)|(?!.*;):(?=[^;]*$)/m';
$str = 'DTEND;TZID="Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London";20150601T07300001T073000
DTEND;TZID="Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London":20150601T07300001T073000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);