package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{8}-\d{4})_(.{1,})_avl\.properties_(\d{8}-\d{4})_(.{1,})_avl.properties_(\d{8})\.txt$`)
var str = `20160330-1136_brandproduct_avl.properties_20160330-1255_brandproduct_avl.properties_20160330.txt
20160330-1136_brandproduct_avl.properties_20160330-1255_brandproduct_avl.properties_20160330.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}