using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*J(\w))(?=.+Q\1)(?=.*T\1)(?=.*K\1)(?=.*A\1).*$";
string input = @"TD JD QD KD AD
AD KD QD JD TD
KD TD QD AD JD
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}