const regex = /^(?=.*J(\w))(?=.+Q\1)(?=.*T\1)(?=.*K\1)(?=.*A\1).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*J(\\w))(?=.+Q\\1)(?=.*T\\1)(?=.*K\\1)(?=.*A\\1).*$', 'gm')
const str = `TD JD QD KD AD
AD KD QD JD TD
KD TD QD AD JD
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}