import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "if \\(([^\\$]+\\$\\<\\>[^ ]+)[^\\}]+\\(null, ([^;]+)\\);\\s+\\}\\s+([^;]+)\\1(.*;)";
        final String string = "get\n"
	 + "{\n"
	 + "int num;\n"
	 + "lock (this.queueLock)\n"
	 + "{\n"
	 + "if (Journal.CS$<>9__CachedAnonymousMethodDelegate7 == null)\n"
	 + "{\n"
	 + "Journal.CS$<>9__CachedAnonymousMethodDelegate7 = new Func<ApiBlob, int>(null, (ApiBlob blob) => Encoding.UTF8.GetByteCount(blob.DataString));\n"
	 + "}\n"
	 + "num = this.Sum<ApiBlob>(Journal.CS$<>9__CachedAnonymousMethodDelegate7);\n"
	 + "}\n"
	 + "return num;\n"
	 + "}\n"
	 + "}";
        final String subst = "\\3\\2\\4";
        
        final Pattern pattern = Pattern.compile(regex);
        final Matcher matcher = pattern.matcher(string);
        
        // The substituted value will be contained in the result variable
        final String result = matcher.replaceFirst(subst);
        
        System.out.println("Substitution result: " + result);
    }
}