Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\$\{\w+?\}|%\(\w+?\)s|<%=\w+?%>
/
g
Input 1
1
New
foobar ${name} barfoo ${name2} or ${ name3 } foobar {no} 50% off of $50 foobar {${name}} barfoo {${name2}} or { ${ name3 } } foobar {no} 50% off of $50 foobar %(name)s barfoo %(name2)s or %( name2 )s foobar {no} 50% off of ($50) foobar <%=name%> barfoo <%=name2%> or <%= name3 %> foobar {no} 50% off of $50 <element>here</element> there