package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^>\n]*>){0,3}[^>\n]*`)
var str = `afsad>adfsaf>asfasf>afasdX>asdffs>asfdf>
23433>433453>4>4559>455>3433>
adfd>adafs>afadsf>
test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}