use strict;
my $str = 'afsad>adfsaf>asfasf>afasdX>asdffs>asfdf>
23433>433453>4>4559>455>3433>
adfd>adafs>afadsf>
test';
my $regex = qr/^(?:[^>\n]*>){0,3}[^>\n]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}