// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[^>\n]*>){0,3}[^>\n]*").unwrap();
let string = "afsad>adfsaf>asfasf>afasdX>asdffs>asfdf>
23433>433453>4>4559>455>3433>
adfd>adafs>afadsf>
test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}