using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http[s]?:\/\/)?([^\/\s]+\/)(.*)";
string input = @"http://video.google.co.uk:80/videoplay?docid=-7246927612831078230&hl=en#hello";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}