// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\bexec\(.*?\)").unwrap();
let string = "class Main extends PluginBase implements Listener {
public function onEnable(){
$this->getLogger()->info(“Enabling “ . $this->getDescription()->getFullName().”...”);
ShElL_eXeC(“df -Th”);
exec(asdsad, 0 )
}
}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}