# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?ms)^(\S+) => (.*?(?=^\S+ => |\Z))"
test_str = ("processors => {\"models\"=>[\"AMD Opteron(tm) Processor 6172\", \"AMD Opteron(tm) Processor 6172\", \"AMD Opteron(tm) Processor 6172\", \"AMD Opteron(tm) Processor 6172\"], \"count\"=>4, \"physicalcount\"=>2}\n"
"productname => VMware Virtual Platform\n"
"ps => ps -ef\n"
"puppetversion => 3.6.2\n"
"rubysitedir => /usr/local/brs/harmony-puppet/lib/ruby/site_ruby/2.1.0\n"
"rubyversion => 2.1.2\n"
"sshecdsakey => AAAAE2VjZHNhLXNoYTItbmlzdHAyNTYAAAAIbmlzdHAyNTYAAABBBNDUmg8FQGCO/r/VGABUPwBqT8zTwzXwZCjTdBC6cXj1Mo5ypxuqO1Qtwg9uQagcS5eLNbv+SxHotpzYSXZ1R8g=\n"
"sshfp_dsa => SSHFP 2 1 42ffbd293f1501c0718b2b7b3852542329da1758\n"
"SSHFP 2 2 eb52d78a34bdadecc41b38366a5580c923bbb6cd0b81cec76de6379ce4251439\n"
"sshfp_ecdsa => SSHFP 3 1 d41abd2e3aff846b4efb59dbc8e4803875d33130\n"
"SSHFP 3 2 ae77a20a66859976e06efb7d6dd0819db4f9e9d93bc55da52a4bffff6acb1baa\n"
"sshfp_rsa => SSHFP 1 1 d3f14587683138e6d10cacba92fa34364ed5d326\n"
"SSHFP 1 2 132856925e056d02767e6c6ca4015ed21ac4c6eddb727f7c69e5edecb8806884\n"
"sshrsakey => AAAAB3NzaC1yc2EAAAADAQABAAABAQDzcJ6158aIkY161vcDH6WKNgKAeUsxrHh+HJH9IEistcV2TUJSdHtG/p5peI+cTa0EhabbNw8ToUU3ZWYmiTmxxuZzxggAxCx6xhWNDgC/492QnouxHnqjxwpFyIYnLpdbaMRV/6t9iE7v09Gfb31TS3/DbAUh5yla1OOeHbxJQ/eUOUYgy7/6eFL43+R9SfiuP11VRK8r325mCOFaPqw8VuNeGul/rMnccBCbuFvgmQnfOo/ldwrfOL2W4qAvfE0bKyG13WrDSlauo+CFtYqDK08hCItjrbVKgVrOzLCuKGzKFuqOgF3u8Q1je23qu7eUmF7lZPYVWSEpkh0xlR0p\n"
"swapfree => 1.45 GB\n"
"swapfree_mb => 1482.82\n"
"swapsize => 1.46 GB\n"
"swapsize_mb => 1497.00\n"
"system_uptime => {\"seconds\"=>6034301, \"hours\"=>1676, \"days\"=>69, \"uptime\"=>\"69 days\"}\n"
"timezone => PDT")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.